1

Hi I followed Vitalik's instructions for using the splitter contract.

I used Wallet 8.1, on the fork chain to send ETH from my etherbase account to the splitter contract targeting a fresh ETC wallet on the non-fork chain (also etherbase), and refunding a 2nd etherbase account on my ETH wallet.

etherbaseYesFork A -- >  Splitter Contract \ --- etherbaseYesFork B
                                            \ -----  etherebaseNoFork A

This transaction for 1 ETH went through, and split correctly into both ETH and ETC accounts.

However I followed with 2 more transactions and over 1 hour later they don't appear in the ETC Chain, they are correctly being moved in the ETH chain to the account.

Here is the first and successful transaction: http://etherscan.io/tx/0xd74b6861c47dffe68393593b13320269c49336f2342ad9b5ff8147d745c9b00f

Here is the follow up, that still has not appeared in my ETC Wallet (No Fork Chain). http://etherscan.io/tx/0x73b3ef8fc2f4b544e36617cfb20f3edbc61db3b01dfbee4c1af034845dc1c4f5

Any ideas what went wrong?

** Corrected the links -

Wallet Address: 
ETH : 0x0d1af24b05015fa6ef57493bb3697e75c28ef0bc1
ETC : 0x0fdde2c8255e661ecece17b0ac431d5f7caf6a2e
  • the transaction hashes you gave here are identical – Roland Kofler Aug 1 '16 at 7:20
  • and it would be helpful to have the address of your ETC wallet too – Roland Kofler Aug 1 '16 at 7:23
  • My bad on the 2nd hash. etherscan.io/tx/… – jj_jameson Aug 1 '16 at 7:34
  • I corrected the links, and added my wallet address. – jj_jameson Aug 1 '16 at 7:48
1

I did a very similar thing and then realized that my ETH account had more ETH in it than it did when the hard fork occurred.

For example, if the ETH account had 10 ether in it at the fork, then 10 ETC were in the account corresponding ETC account.

Later, I added 2 new ether to the ETH account, so I had 12 ETH but I still only 10 on the ETC side.

When I tried to send all 12 ETH to a new account using a splitter contract, the transaction went through, but the replay on the ETC side failed because that account didn't have 12 ETC (it only had 10).

I then went back and tried again but only sent 10 ETH, and this time the ETC replay went through.

Not sure if this is your situation, but this is what worked for me.

  • 1
    Thanks, that's probably the case, I believe the account had only 1 ETH because it was in the DAO, and I moved in ETH into it after the Fork and I was able to recove the DAO funds. Awesome, hadn't realize that. – jj_jameson Aug 1 '16 at 17:38
  • Just wanted to follow up that I was able to utilize a prefork wallet that did have an ETH balance and the splitter contract worked like a charm. It relayed the transactions to both networks cleanly. – jj_jameson Aug 2 '16 at 13:11
  • Glad I could help – Thomas Jay Rush Aug 2 '16 at 18:34
1

Your transaction most likely isn't getting replayed on the ETC chain. You are better off syncing your own ETC chain. To do so:

  1. In Mist, Develop -> "The DAO fork" -> Don't Support
  2. Rename your chaindata folder
  3. Open Mist and let it sync
  4. Use a splitter contract on the ETC chain

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.