1

i am trying to create private POA network in which i have 3 aws ec2 ubuntu servers. on 1st server bootnode and on 2nd server POA node1 is running and on 3rd server POA node 2 running. but i am not able to connect the node1 and node2 also bootnode shows this error when i tried to just node2 to connect to

DEBUG[09-17|02:27:35.307] ENR request failed id=7498feef0de4a2e6 addr=@ip:30312 err="invalid IP in response record: loopback address from non-loopback host"

  • I think, any of the deployed geth nodes is using non-loopback address and other one is using loopback address. When bootnode gets a request of findNode and handles it, it finds that one is loopback and another one is non. So, it gives the error response. – Md Rayhanul Masud Saom Sep 18 at 4:25
1

You need to enable UDP rule for port 30310 for ec2 instance running bootnode.

Problem while setting private ethereum network on AWS using bootnode

  • thanks in advance!! let me check and get back to you.. – ash Sep 19 at 17:44
  • i just realise when i use bootnode -nodekey boot.key -verbosity 9 -addr :30310 command to setup bootnode it gives self=enode://somenode@127.0.0.1:30310 .. that 127.0.0.1 is problem i guess. also i tried using bootnode -nodekey boot.key -verbosity 9 -addr 0.0.0.0:30310 still 127.0.0.1 remains same – ash Sep 28 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.