0

I have geth running on rinkeby network and successfully used clef as a signer using command.

clef --keystore ~/.ethereum/rinkeby/keystore --chainid 4 --stdio-ui

Also started geth with clef as signer using :

geth --rinkeby --rpc --syncmode "light" --rpcport 8543 --rpcaddr 192.168.0.120 --rpccorsdomain "*" --port "35555" --rpcapi "eth,net,web3,personal,miner,admin" --signer=/home/ayanworks/.clef/clef.ipc

Then I connected geth with rpc using

geth attach rpc:http://192.168.0.120:8543 and hit eth.accounts

After that, on clef terminal, I get the following output.

In this scenario, I am not getting prompt to approve request for y/n on clef terminal.

Please update if I am following the wrong setup steps

clef --stdio-ui output for approving account list

0

When you are using the --stdio-ui parameter, you have to interact in json format. For example to reply with your password phrase use:

{"jsonrpc":"2.0","id":1,"result":{"text": "password phrase"}}

When experimenting it is easier to start without the --stdio-ui parameter, then you can just paste the password and enter anwers like "y".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.