0

Python version : 3.5.2. web3 version : 4.9.2. Ubuntu : 16.04. Also tried previous version of web3: 4.0.0

closed as off-topic by Achala Dissanayake, Ismael, shane, alberto, Richard Horrocks Sep 9 at 17:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Ethereum, the decentralized application platform and smart contract enabled blockchain, within the scope defined in the help center." – Achala Dissanayake, Ismael, shane, alberto, Richard Horrocks
If this question can be reworded to fit the rules in the help center, please edit the question.

  • if this fixed your problem please mark my response as answer. thanks – Niklas Feurstein Sep 9 at 13:27
4

This is a very common error.

You need to upgrade your python version.

Web3 requires at least 3.5.3+

I hope this resolved your problem :D

Not the answer you're looking for? Browse other questions tagged or ask your own question.