0

I used the command truffle unbox react to build a dapp. It is just the initial step of my dapp development. However, it sucks. It continually pops up

gyp ERR! build error
gyp ERR! stack Error: `C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\MSBuild\15.0\Bin\MSBuild.exe` failed with exit code: 1

this error. I've already google this error. Therefore, I set my python default version at 2.7 and install visual studio 2015 and visual studio 2017. Also I've reinstall node-gyp and npm to make sure if it is the latest version. I've tried whatever I can google. PLEASE HELP! This is my error

  • Have you tried a one-time execution of npm install --global --production windows-build-tools? – goodvibration Sep 5 at 12:22
  • @goodvibration I've already tried this command. – Jessie Sep 5 at 12:53
  • And did it complete successfully? – goodvibration Sep 5 at 12:55
  • Yes, it completed successfully. – Jessie Sep 5 at 12:56
0

Hey I was just going through this issue. I solved it by locally installing an earlier version of node. First, I deleted all my node modules and package-lock.json.

Then I installed an earlier version of node locally

npm install --save node@8.10.0

Then I re-installed all my other node packages

npm install --save drizzle drizzle-react drizzle components

Hope this might help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.