4

I had no issues before, but my syncing has gotten incredibly slow with geth. My system time and date are good (set by ntp) so that shouldn't be the issue and my Internet connexion works fine.

It took 2 hours to get 2048 blocks. Even the highest block parameter is wrong! (as of now, etherchain.org reports that the highest block is 1953411) What gives?

I0725 18:40:30.199394 core/blockchain.go:972] imported 2048 block(s) (0 queued 0 ignored) including 13408 txs in 2h8m18.691083833s. #1888377 [6328a321 / 2ab5bd5c]

eth.syncing { currentBlock: 1889280, highestBlock: 1947463, knownStates: 0, pulledStates: 0, startingBlock: 1849273 }

Any idea on how to troubleshoot this, or avoid the issue?

EDIT: running with 1.5.0 seems to be the problem. Downgrading to 1.4.10 fixed the issue

2

You are on the non-forked chain.

From http://fork.ethstats.net/:

enter image description here

The non-forked chain (Ethereum Classic / ETC) does not have many clients or miners and you would therefore experience the slow syncing.

If you intend to be on the hard-forked chain, you will have to specify the geth option:

geth --support-dao-fork console

If you want to fast sync, you will firstly have to remove your current chain:

geth removedb

The start the fast sync:

geth --support-dao-fork --fast console

Also, you will need to be using geth v 1.4.10 or above

geth version
Geth
Version: 1.4.10-stable
...

You can check which chain geth is configured to use by typing:

geth console
...
I0726 13:16:17.848871 cmd/utils/flags.go:842] ------------------------------------------------------------------------------------------------
I0726 13:16:17.848917 cmd/utils/flags.go:843] Geth is currently configured to SUPPORT the DAO hard-fork!
I0726 13:16:17.848936 cmd/utils/flags.go:844] You can change your choice prior to block #1920000 with --support-dao-fork or --oppose-dao-fork.
I0726 13:16:17.848955 cmd/utils/flags.go:845] After the hard-fork block #1920000 passed, changing chains requires a resync from scratch!
I0726 13:16:17.848973 cmd/utils/flags.go:846] ------------------------------------------------------------------------------------------------


See also:

  • Oh weird, I thought the latest geth from Ethereum's ppa had the hard fork on by default – Arthur B Jul 26 '16 at 3:09
  • Yes. There is a message "If no fork choice was ever provided, Geth will default to supporting the fork per the majority vote." in github.com/ethereum/go-ethereum/releases stating so. If you have chosen --oppose-dao-fork in the past, this setting will persist until you change it with the parameter --support-dao-fork. – Bokky WeAreAllAssange PooBah Jul 26 '16 at 3:19
  • 1
    I have not though. I never ran geth with any flag – Arthur B Jul 26 '16 at 3:21
  • Geth console does not mention anything about being on a certain chain... I'm running 1.5.0 – Arthur B Jul 26 '16 at 3:25
  • 1
    Ok 1.5.0 is just not working. Downgraded to 1.4.10 and the problem seems to have gone away. – Arthur B Jul 26 '16 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.