0

while following this or this solution I found nowhere any file to make change for allowUnlimitedContractSize = true so my problem is same as in link but how I can change this in Ganache v 2.1.0

  • Ganache is currently on v6.5.1. Why on earth are you using v2.1.0? – goodvibration Aug 7 '19 at 11:12
  • Also, it is not clear (possibly due to poor English) what you mean by "I found nowhere any file to make change". What does "file" have to do with this??? You should simply pass --allowUnlimitedContractSize when you start Ganache. The documentation for that is here. Please note that it actually recommends NOT to use it, since your testing env will subsequently behave different from production (hence the primary purpose of your testing will not be fulfilled). – goodvibration Aug 7 '19 at 11:15
  • @goodvibration i think he mean the ganache ui not ganache-cli he can't config his ganache ui to allow unlimited contract size – haxerl Aug 7 '19 at 11:54
  • right @goodvibration I am using Ganache UI so the version is v2.1.0, and as in the given link , I am not able to find this file Windows: %APPDATA%\Ganache\Settings so where I can change the contract size limit ?, and I tested the same contract on remix and deployed successfully, tried all possibilities of gas and gas limit change, no success, then in above link I came to know that it is due to the limit of contract size – FLAME'S KING Aug 7 '19 at 12:16
0

I removed the Ganache UI as in this very limited custom commands in settings, and installed Ganache-cli and use ganache-cli --allowUnlimitedContractSize --gasLimit 0xFFFFFFFFFFFF command to start Ganache , and my problem of "out of gas" solved

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.