I created a Node 0 and exited before creating Node 1. Then I created Node 1. And using Admin API, I connected Node 1 to Node 0.

Node 1 is up and running. How do I start Node 0 and sync it with Node 1?

Or is it already synced?


Edit: This is how I installed ethereum in Lubuntu 16.04

sudo apt-get install software-properties-common
sudo add-apt-repository -y ppa:ethereum/ehtereum
sudo apt-get update
sudo apt-get install ethereum

Then I ran these commands to create new account

1) geth --datadir ./ account new
2) geth --datadir ./ init customgenesis.json 
3) geth --datadir ./ --networkid 15 --port 30300 console

Now, 3rd command starts a Geth JavaScript console. So I proceed to run 4th command:

4) geth --datadir ./ account new

Upon this, I get this error:

(anonymous): Line 1:8 Unexpected identifier (and 1 more errors)

No problem. I start a new terminal and rerun the 4th command and it runs fine. Now when I run the 5th command,

5) geth --datadir ./ init customgenesis.json 

I get the following error:

Fatal: Failed to open database: resource temporarily unavailable

So I go to first terminal where I created Node 0 and typed exit. Then I reran the 5th commands on the second terminal and command worked. Then I proceeded to run the following commands and they both worked fine:

6) geth --datadir ./ --networkid 15 --port 30301 console

7) admin.addPeer(enode://8cc8dcb50102ac095e6c5de080cff7cc2d66ac4be8093551ba31c60bb315500b68d4cbe2593df6b8e6d35ebd09fb5399a246d67349d9128182caf453df3f3493@

Now, what does it mean?

1) Node 0 is off since I exited out of it? 2) Only Node 1 is up? If I understand correctly, both are sharing the same network ID but different ports, hence there shouldn't be any problem running both nodes?

Any insight would be appreciated. Thanks.

  • are you using the same machine? for adding nodes you can use addpeer() in one of your nodes then they will sync automaticaly
    – Badr Bellaj
    Commented Aug 3, 2019 at 11:39
  • Is this pantheon?
    – 0xsegfault
    Commented Aug 3, 2019 at 14:55
  • Hello. I have edited my question to include more information Commented Aug 4, 2019 at 1:54
  • related question ethereum.stackexchange.com/questions/7006/…
    – Badr Bellaj
    Commented Aug 4, 2019 at 11:08

1 Answer 1


Your problem as i understand it is using two nodes with the same data directory (--datadir) which is impossible !!

to run two nodes you have to use two different directories and different ports.

First initiate a node

geth -verbosity 3 --datadir="./node1" init genesis.json 

Then run it

geth -verbosity 3 --datadir="./node1" --networkid 15 --ipcdisable --port 30301 console 

Then run the second node in the same way on a different port (30302) and different datadir --datadir="./node2"


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.