6

I want to mine Ether and I've been trying to sync blockchains for days.

I've tried using geth --fast command and it always stuck as in the picture.

screenshot

My computer is running 64 bit Windows 10 with geth 1.4.10 installed. I've also tried using geth --rpc but it gave me the same result. I'd guessed that it was because my ISP blocks P2P connection but after I try connecting via VPN nothing's changed.

I've already set my time synchronization to be with time.nist.gov as some soln I've found suggest.

Also I have trouble with MIST hang up on 'seeking peers' on startup without any progress.

What should I do to get this stuff done?

  • Is admin.peers also empty? (I'm assuming it would be if you're stuck "seeking peers".) Ensure that TCP and UDP ports 30303 are forwarded properly through any firewall you might have. – Richard Horrocks Jul 22 '16 at 15:15
  • @RichardHorrocks Yes, net.peerCount returns 0. I've manually tried connecting to peer using admin.addPeer() but it failed. – saris Jul 23 '16 at 4:45
2

I think the clue here is the message "WARNING: Wrote default Ethereum genesis block".

I would try renaming the default datadir (see Not syncing due to "unhandled trie error: missing trie node" for paths) then try geth --fast console.

You can copy the keystore within the datadir from your old datadir to your new datadir to save your accounts. And if successful, then remove your old renamed datadir

Alternatively you can try running geth removedb to remove the blockchain and state database. Then run geth --fast console.



The Warning

The warning is emitted from go-ethereum - eth/backend.go, lines 239-248, and it seems that geth cannot find the genesis block so it writes a new one. The source code follows:

// load the genesis block or write a new one if no genesis
// block is prenent in the database.
genesis := core.GetBlock(chainDb, core.GetCanonicalHash(chainDb, 0))
if genesis == nil {
    genesis, err = core.WriteDefaultGenesisBlock(chainDb)
    if err != nil {
        return nil, err
    }
    glog.V(logger.Info).Infoln("WARNING: Wrote default ethereum genesis block")
}
  • Thanks for respond! What should I name the defaultdir ? I've already try removedb before I post the question but it didn't help. – saris Jul 23 '16 at 7:11
  • I usually rename my directory {old directory name}_pre_20160723 . The removedb will remove the chain data, but not the configs. – Bokky WeAreAllAssange PooBah Jul 23 '16 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.