1

I believe the withdrawal process for my test amount of DAO to be withdrawn to Ether got stuck after the approval function, it now shows 0 amount of DAO but Ether didn't increase. Can I manually resume, i.e. invoke the next function or is it going to be more complicated than that?

This is the address in question: 0xC4Da809d8071704F01B403b781877E4A0Feef01D

0

This transaction shows that you have successfully called TheDAO.approve(...), the first step described in How do I convert my The DAO tokens into ethers using the withdrawal contract after the hard fork?.

What is remaining is to call the second step theDAOWithdrawal.withdraw(...).

You cannot manually resume with MyEtherWallet as it executes both TheDAO.approve(...) and theDAOWithdrawal.withdraw(...) in the one go.

The TheDAO.approve(...) function can however be called more than once, so you can just re-run the MyEtherWallet Withdraw your DAO Tokens for ETH. You will end up paying ~ 0.00095508 Ether ($0.01) extra as this is the transaction fee for calling TheDAO.approve(...) a second time.

Or if you have the Ethereum Wallet installed and synced, you can just run the Execute The Withdrawal Contract Function section under Withdrawal Method 2 - Ethereum Wallet described in How do I convert my The DAO tokens into ethers using the withdrawal contract after the hard fork?.

What I don't understand is why MyEtherWallet only executed the first TheDAO.approve(...) part and not the second theDAOWithdrawal.withdraw(...) part. The generateAndSendWithdrawTx function in https://www.myetherwallet.com/js/etherwallet-master.js executes both parts in the same function.

  • 1
    Yep that I didn't understand either. Thanks! I shall try again and then report on the outcome, should be able to afford the 0.01$ ;) – Johnny Due Jul 22 '16 at 13:43
  • 1
    It seems that myetherwallet is experiencing some issues, tried with different browsers, and the site is sometimes (partly) down. I'll wait for now or try with Mist – Johnny Due Jul 22 '16 at 13:54
  • @tayvano on thedao.slack.com posted "just fixed mew error" – The Officious BokkyPooBah Jul 22 '16 at 16:02
  • 1
    Alright, did it again, now it worked, thanks you guys! – Johnny Due Jul 22 '16 at 16:33
  • Is there something broken again? I tried to withdraw the dao to eth. But nothing happened. etherscan.io/tx/… There is only TheDAO.approve(...) – PaintedRed Aug 14 '16 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.