Here is my truffle-config.js

networks: {
 ropsten: {
  network_id: 3,
  host: '',
  port: 8545,
  gas: 4000000,
  from: "address_in_metamask"

I ran a geth node using the command:

geth --cache=1048 --testnet --unlock "address_in_metamask" --rpc --rpcapi "eth,net,web3" --rpccorsdomain '*' --rpcaddr localhost --rpcport 8545

After this in another tab, I ran the command

truffle migrate --network ropsten

I expected the smart contract to be deployed. But then I get the message as

Compiling your contracts...
> Everything is up to date, there is nothing to compile.

Migrations dry-run (simulation)
> Network name:    'ropsten-fork'
> Network id:      3
> Block gas limit: 0x1e8480


Deploying 'Migrations'
Error: Error: Error:  *** Deployment Failed ***

"Migrations" -- sender account not recognized.

at Object.run 
at process._tickCallback (internal/process/next_tick.js:68:7)
Truffle v5.0.18 (core: 5.0.18)
Node v10.16.0

I have given the correct account address from Metamask which has enough ethers, yet it's not working. Please help.

Thank you.


In many cases I've found that the truffle-hdwallet-provider version causes various issues.

You can try updating your version to truffle-hdwallet-provider@1.0.0-web3one.0.

Do npm install truffle-hdwallet-provider@1.0.0-web3one.0. It might be due to various dependency conflict issues.

  • i want to do it without hdwallet – Shailesh Mishra Jul 21 '19 at 17:01
  • truffle-hdwallet is a provider. You need some sort of provider to connect with the eth node. You can use the WebSocketProvider. – Tirtha Jul 22 '19 at 3:50
  • I am trying to deploy the same way as it is given here - (ethereum.stackexchange.com/questions/26365/…). @Tirtha can you please tell where is the catch? I am new to this. Thank you. – Shailesh Mishra Jul 24 '19 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.