7

I've gone through he entire process here and am hung up on this last step; it says I don't have enough gas to execute the withdrawal. What do I do here? step by step would be super helpful!! thanks!!

Here is the last step in the process I followed:

Execute The Withdrawal Contract Function

  1. Withdraw ETH from the Withdrawal contract
  2. In the Contract menu, select The DAO Withdrawal contract
  3. Under the Write To Contract column on the right, select the Withdraw function.
  4. Under the Execute from field, select the account from which you want to convert your DAOs into ETHs.
  5. Click on Execute and enter your account password.
  6. You should get a transaction confirmation message.
  7. Wait a short while and your ether balance should update. If not, restart Ethereum Wallet.

    enter image description here

2

I had the same problem, it is caused by failing to approve the withdrawal in the primary DAO.

When following Withdrawal Method 2 - Ethereum Wallet instructions from this post: How do I convert my The DAO tokens into ethers using the withdrawal contract after the hard fork?

It is important to follow the step: Approve The Transfer Of Your DAOs To The Withdrawal Contract.

Once you have approved The DAO Withdrawal contract by sending a transaction to The DAO, the "consumed all gas" error upon withdrawal disappears.

The error shows as a "consumed all gas" because if you try to withdraw DAOs before approving the withdrawal, the withdrawal contract throws an exception which consumes all the gas in the transaction. Luckily the Ethereum Wallet won't let you submit this erroneous transaction and instead saves you from wasting your Ether by means of consuming all gas.

  • I'm still having the consumed all gas error, even after approving the withdrawal in the DAO contract, twice. – Richard Anthony Hein Jul 25 '16 at 17:49
2

I had this same problem. Turns out my DAO was in a wallet contract that I had to delete due to the phishing attack bug. Luckily I still had the address for that wallet saved, so I could upload it, give it a bit of Ether, and call the approve function from there. That solved the error in the Estimated fee consumption field, but unfortunately I was still running into another gas limit issue:

Error: Exceeds block gas limit

EDIT: It turns out that Ethereum Wallet was estimating a ridiculously high gas fee, close to 50,000,000 gas, while the current block gas limit is around 4,700,000. So I dropped the gas down to that amount, and the transaction appeared to go through, but I did not receive any Ether... Upon further investigation, it appears my contract call only successfully executed one out of five internal transactions. Looking at the transaction on EtherScan, the rest of the process failed:

Internal transactions failed

So now I'm stumped...

EDIT AGAIN: I finally managed to get my Ether out by first transferring my DAO from the wallet contract to my account address! It seems a wallet contract can't receive a withdrawal. I hope this helps! I know I'm happy now :)

  • +1 but... I'm stuck with the same problem. What do you mean by "transferring my DAO from the wallet contract to my account address"? How do you do that? Is this something you do from Mist? – Cedric Martin Sep 6 '16 at 13:47
1

You need to give the account where you hold your DAO tokens a little bit more Ether.
This is because also the Withdrawal contract and the DAO tokens are contracts you run with ETH and it seems you don't have any on your contract, or did not include the suggested fee in the withdrawal transaction

You can withdraw the rest later without any problems. I suggest you give 50 USD cents worth of ETH to your DAO wallet, this is enough. The rest of the 50 cents is added to the ETH you get back from the Withdrawal contract.

  • I am still having trouble here. I have 0.9 ether in my main account and I have done what you suggested, however when I attempt to do a withdrawal, it still is telling me that I don't have enough gas. This is really strange. Im only trying to transfer $1000 usd. I am basically following the instructions from this site here: The step #3 has worked(approved the transfer of the dao contract) and the first step from the executing the withdrawal contract is giving me this gas problem LOL tinyurl.com/zo79rwu – Johnny Be ReallyGood Jul 24 '16 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.