I'm trying to deploy my smart contract serverless(AWS lambda) and I'm using Truffle framework.

The code is getting deployed in an earlier system(earlier it was deployed here). Now I have updated the smart contract version .When I am deploying it. I am not able to in my new system due to dependencies mismatch n version change.I tested my smart contract in local system using ganache. there uts working fine. When deploying serverless I am getting the issue.

Below is the error screenshot

enter image description here - Below are the dependencies in package.json.

"aws-sdk": "^2.256.1",
"express": "^4.16.3",
"fs": "0.0.1-security",
"openzeppelin-solidity": "^1.12.0",
"pug": "^2.0.3",
"solc": "^0.4.24",
"web3": "^1.0.0-beta.50"

and all the above have been updated to newer versions.. 0

above were the earlier dependencies in which the project was executible.Now I have updated to below dependencies-- "aws-sdk": "^2.489.0", "express": "^4.17.1", "fs": "0.0.2", "openzeppelin-solidity": "^2.3.0", "pug": "^2.0.4", "solc": "^0.5.10", "truffle": "^5.0.26", "truffle-hdwallet-provider": "^1.0.13", "web3": "^1.0.0-beta.52" } even though the package.json file is updated the package-lock.json file is in the older version ...n despite several tries (using ncu -u -->npm install)..still package-lock is not getting updated


Try to Upgrade web3 to 1.0.0-beta55 and add "null" as second parameter like this

const web3 = new Web3('http://......', null, options);

  • above were the earlier dependencies in which the project was executible .Now I have updated to below dependencies-- "dependencies": { "aws-sdk": "^2.489.0", "express": "^4.17.1", "fs": "0.0.2", "openzeppelin-solidity": "^2.3.0", "pug": "^2.0.4", "solc": "^0.5.10", "truffle": "^5.0.26", "truffle-hdwallet-provider": "^1.0.13", "web3": "^1.0.0-beta.52" } }
    – Ashadipta
    Jul 12 '19 at 5:24
  • "^1.0.0-beta.52" this "^" is tricky, what i know that web3 added the "null" in the current versions , sorry cant help more without seeing your code
    – Majd TL
    Jul 12 '19 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.