0

require("babel-register"); require("babel-polyfill"); require("dotenv"),config();

module.exports = { networks: { development: { host: "127.0.0.1", port: 7547, network_id: "*" } }, contracts_directory: './source/contracts/', contracts_build_directory: './src/abis/', compilers: { solc: { optimizer: { enabled: true, runs: 200 } } } }

closed as unclear what you're asking by shane, alberto, Achala Dissanayake, eth Jul 13 at 8:20

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I keep getting config not defined using Truffle Compile v5.0.26 (core: 5.0.26) Node v9.10.0 – Tony Johnson Jul 9 at 17:27
0

It appears you have a typo, a comma should be a full stop.

Your Truffle config truffle-config.js has require("dotenv"),config(); when it should be require('dotenv').config();

Not the answer you're looking for? Browse other questions tagged or ask your own question.