1

i have my private ethereum blockchain but i need it to run in https://localhost:8545 or https://0.0.0.0:8545. currently it tun in http://0.0.0.0:8545 but when i try to connect it with Myethereumwallet it shows the below error.

"Mixed Content: The page at 'https://localhost:8080/#/' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://0.0.0.0:8545/'. This request has been blocked; the content must be served over HTTPS."

0

This is an error from your Chrome web browser. You can disable mixed content security policy in settings or from command line.

https://stackoverflow.com/questions/18321032/how-to-get-chrome-to-allow-mixed-content

I recommend disabling it from the command line and not using the web browser for anything else, as you are disabling a security feature.

Alternatively you can setup a localhost web development proxy server with HTTPS but it is little bit more work:

https://blog.filippo.io/mkcert-valid-https-certificates-for-localhost/

| improve this answer | |
  • but after that i have change the host localhost to 127.0.0.1 in myetherwallet host.after that it works without that error – vishnu Jul 5 '19 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.