1

I set up a chique poa ethereum private chain. the node can start to work using the command below:

geth --networkid 123456 --rpc --rpcport "8545" --rpcaddr 0.0.0.0 --rpccorsdomain "*" --datadir ./node1/data --syncmode 'full' --port "30301"  --rpcaddr "0.0.0.0" --rpcapi "admin,db,eth,miner,web3,net,personal,txpool" --unlock '0x731c68c093dae541baf59616b7f7cd800dfe7de8' --password passfile --mine

I generated a toml config file usding the command:

geth --networkid 123456 --rpc --rpcport "8545" --rpcaddr 0.0.0.0 --rpccorsdomain "*" --datadir ./node1/data --syncmode 'full' --port "30301"  --rpcaddr "0.0.0.0" --rpcapi "admin,db,eth,miner,web3,net,personal,txpool" --unlock '0x731c68c093dae541baf59616b7f7cd800dfe7de8' --password passfile --mine dumpconfig > config.toml

for this way, when I lauch the node by command:

geth --config ./config.toml

the node can not work and be stuck at:

INFO [06-25|05:36:03.943] Started P2P networking                   self=enode://e37dbb1464b9af5404ef337c64cd22061228e8f19552949ef9d9754ae74f5574f0a7fd13b7ebc5dce6b74d87be610f0fa4855b3086c9ebfe7b7c3ace950946dc@127.0.0.1:30301

So how can I use toml config file in private ethereum chain correctly?

Thanks.

0

I think the issue is that you are using --mine flag and this one is not supported in geth's config file

check out this github issue : https://github.com/ethereum/go-ethereum/issues/17638

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.