0

I am trying to build an ethereum private network. Here is my genesis.json file

{
"config": {
"chainId": 15,
"homesteadBlock": 0,
"eip155Block": 0,
"eip158Block": 0
},
"nonce": "0x0000000000000042",
"mixhash":
"0x0000000000000000000000000000000000000000000000000000000000000000",
"difficulty": "0x200",
"alloc": {},
"coinbase": "0x0000000000000000000000000000000000000000",
"timestamp": "0x00",
"parentHash":
"0x0000000000000000000000000000000000000000000000000000000000000000",
"gasLimit": "0xffffffff",
"alloc": {
}
}

I run these commands

geth --datadir ~/.ethereum/privatenet/ init ~/.private_ether/genesis.json

geth --datadir="consert" --networkid 15 --rpc --rpcport "8545" --rpcaddr "localhost" --rpccorsdomain "*" --rpcapi "eth,net,web3,miner,debug,personal,rpc" --nodiscover console 2>> eth.log

I create an account and when I mine.start() the eth.log says

Commit new mining work number=1 sealhash=6013c0…d2f782 uncles=0 txs=0 gas=0 fees=0 elapsed=664.391µs

and that's it! I cant mine. Eth.hashrate returns 97316 and eth.blockNumber is 0

I tried to run this command then

geth --datadir ~/.ethereum/privatenet/ --nodiscover console 2>>eth.log

and it works I can mine. But I have 2 nodes with same settings and when I go to create an admin the command admin.addPeer returns truth and the ethlog returns

Dropping unsynced node during fast sync id=1a34b7637a 42eabe conn=staticdial addr=83.212.75.112:30303 type=Geth/v1.8.27-stable-4bcc0a37/linux-amd64/go1.10.4

and the admin list is empty.

  • You have two problems: mining and communication between nodes. First try one of them, you can increment verbosity parameter of geth to --verbosity 5. – Ismael Jun 21 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.