I'm trying to connect geth with truffle to deploy my contracts to my testrpc. When I run truffle deploy it's running but when I do http://localhost:8545/ it's throwing


as JSON is invalid. My geth is working properly and I'm using same ports in geth and truffle. When I do

curl -X POST --data '{"jsonrpc":"2.0","method":"eth_getBalance","params":["0x822a9cba371309c14e2235057fc561156212cd94", "860"],"id":1}' http://localhost:8545

it throws


which I am unable to understand. Where am I going wrong? And is pudding necessary to connect geth and truffle?

I tried this link but no luck Deploying contracts on geth returns Error: connect ECONNREFUSED

  • there were some answers.. where did it go? Jul 19 '16 at 8:03
  • 1
    The answers were deleted as the answer they were attached to contained a malicious scam site link. Could you replicate the results from ethereum.stackexchange.com/questions/6888/… ? Your eth_getBalance RPC request contains "860" as the block number. Does "latest" in the same field make any difference to the results you are returned? Jul 19 '16 at 8:28
  • latest didnt make any difference , but it was returning the correct answer.. i could deploy the test contracts properly.. my doubt is how to proceed further.. localhost:8545 is still giving same 32600 error.. Jul 19 '16 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.