8

Metamask is showing an asterisk near the account balance, and the message "Balance may be outdated". Indeed the balance is outdated.

This is true on all networks (Main, Ropsten, etc.) and different accounts. I'm using Chrome.

On etherscan I can correctly see the updated balance. How can I fix this in Metamask?

enter image description here

6 Answers 6

6

I was having this issue and I just fixed it. For me, I had to right click the metamask icon then make sure that metamask was set to "read and change site data on all sites".

If you can't right click and find this option, try right clicking the icon then clicking on "manage extensions". Then under the Site Access section, click "On All Sites".

That's it. That worked for me. I hope it works for you.

0

Can you show a screenshot? I have never seen this before.

I suggest you try to see if any of following steps solves the problem:

  1. Switch networks up top by clicking on "Main Ethereum Network", and then switching back again.

  2. Try toggling between accounts (if you have multiple).

  3. Fully close your browser and re-open.

  4. Install Metamask using another supported browser (Firefox, Chrome, Brave)

0

This can happen if the system clock is incorrect.

On Windows, try Control Panel > Date and Time > Internet Time > Change settings... > Update now, then restart your browser.

0

this helped "Switch networks up top by clicking on "Main Ethereum Network", and then switching back again."

0

Maybe the Ethereum Mainnet default RPC URL is blocked, make sure the default RPC URL (currently the https://mainnet.infura.io/v3/) is accessible, such as add proxy rule: for *.infura.io.

0

check u can access this site or not:

https://infura.io/

if u can not, get a VPN to make this site can be access. good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.