0

I'm following this example: truffle quorum example I created a cluster using docker-compose and all the nodes are up and running but when I run the truffle migrate command the migration doesn't end and finishes like this:

λ truffle.cmd migrate --reset

Compiling your contracts...
===========================
> Everything is up to date, there is nothing to compile.


Starting migrations...
======================
> Network name:    'development'
> Network id:      10
> Block gas limit: 1702452429


1_initial_migration.js
======================

   Replacing 'Migrations'
   ----------------------
   > transaction hash:    0xbb9fc26e04cd017c3e69a37fd2d0062553c749fd752cbc2f67a1727af519c7e1
   > Blocks: 0            Seconds: 0
   > contract address:    0xd0a5685a4ba479D0FF4E86Ca8300738573816c63
   > account:             0xed9d02e382b34818e88B88a309c7fe71E65f419d
   > balance:             1000000000
   > gas used:            284908
   > gas price:           0 gwei
   > value sent:          0 ETH
   > total cost:          0 ETH


   > Saving migration to chain.
   > Saving artifacts
   -------------------------------------
   > Total cost:                   0 ETH


2_deploy_simplestorage.js
=========================

   Deploying 'SimpleStorage'
   -------------------------

It doesn't give any error but it doesn't finish migrating.

If I remove {privateFor: ["oNspPPgszVUFw0qmGFfWwh1uxVUXgvBxleXORHj07g8="]} from the migrations\2_deploy_simplestorage.js then the migration is able to finish.

I checked the public key of the seventh node and its correct.

How can I run this example?

I'm using Truffle v5.0.7 (core: 5.0.7), Solidity v0.5.0 (solc-js) and Node v10.15.2

Thanks!

0

Truffle version prior to 5.0.14 have some Quorum related bugs. Please upgrade to 5.0.14+ and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.