3

I am getting the following error when running eth or mix:

symbol lookup error: /usr/lib/libdevcrypto.so: undefined symbol:       _ZN8CryptoPP10RandomPool34GenerateIntoBufferedTransformationERNS_22BufferedTransformationERKSsy

Any ideas on how to fix this?

3
  • What system are you on? Where did you get download the binaries, and which versions?
    – Afr
    Jan 27 '16 at 16:36
  • It was working before. I am using Ububtu 15.1. And I installed from the ethereum repo.
    – Terek Judi
    Jan 27 '16 at 16:43
  • Removing and re-installing cpp-ethereum fixed it, but that's not an ideal solution.
    – Terek Judi
    Jan 27 '16 at 16:49
2

Try to reinstall eth, mix and all dependencies:

Ubuntu 14.4

sudo apt-get update
sudo apt-get --reinstall install -y libboost-random1.55.0 libboost-system1.55.0 libboost-thread1.55.0 libc6 libcurl3 libgcc1 libjson-rpc-cpp-dev libjsoncpp0 libreadline6 libstdc++6 ocl-icd-libopencl1 libethereum miniupnpc libleveldb1 libmicrohttpd10 libglu1-mesa freeglut3 libboost-random1.55.0 libboost-system1.55.0 libboost-thread1.55.0 libc6 libgcc1 libjson-rpc-cpp-dev libjsoncpp0 libstdc++6 ocl-icd-libopencl1 libethereum-gui qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtquick-layouts qml-module-qt-labs-settings qml-module-qtwebengine ethereum eth mix

Other Ubuntu versions

Find out the dependencies and reinstall them:

sudo apt-get update
sudo apt-cache depends eth | grep '[ |]Depends: [^<]' | cut -d: -f2 | tr -d ' ' | xargs sudo apt-get --reinstall install -y
sudo apt-cache depends mix | grep '[ |]Depends: [^<]' | cut -d: -f2 | tr -d ' ' | xargs sudo apt-get --reinstall install -y

If this does not do the trick, maybe report the issue upstream.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.