I'm trying to deploy a contract to the Rinkeby Test Network through Remix and Metamask.

Metamask seems to be properly configured:

enter image description here

However, at Remix Run tab, the address dropdown shows no accounts:

enter image description here

If I go to Remix Settings and enable "personal mode", some addresses appear in the dropdown, but they are not my metamask address.

If I try to deploy the contract, I get the following error:

   The method personal_sendTransaction does not exist

At this point I'm a bit lost.

What am I doing wrong?


Remix settiings:

enter image description here

Metamask settings:

enter image description here

However, I'm still getting this error:

Cannot get account list: Error: The method personal_listAccounts does not exist/is not available

I'm using MetaMask @ 6.4.1.

  • 1
    disable Privacy Mode in metamask
    – rstormsf
    Apr 28, 2019 at 0:56
  • That made it work @rstormsf, thank's a lot. However, I think this would not be desirable in the long term. Do you know if there's any other way around it? Apr 30, 2019 at 14:13

1 Answer 1


The reason it is not being read is because this version of Metamask enables privacy mode by default. What this does is require you to approve the application to view/use your wallets on Metamask.

For your specific issue, you have not yet approved Remix to use your accounts, therefore it cannot read your addresses, as you are seeing. To fix this, enable privacy mode by going the the Metamask settings and scrolling to the bottom.

Remix does not ask for permission to use the wallets like most Dapps do, therefore you must enable it in the settings, as opposed to approving the pop-up that you see on the tutorial.

  • It didn't work unfortunately :( See my edits please. Apr 28, 2019 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.