2

I'm trying to use personal_sign and getting not supported error. I'm using web3 v 0.20.1

I first tried using infura and was not able to resolve the issue, so then I connected to a geth node with this setup: geth --rpc --rpcport "8434" --rpccorsdomain "*" --ipcdisable --rpcapi "db,eth,net,web3,personal" --networkid 4

I've not been able to understand how to access this personal_sign method despite being able to access the web3.currentProvider object.

**Edit - seems to now be solved with version 1.0.0 + if the personal flag is set for rpcapi. Is there any way to set this flag when using infura?

0

1 Answer 1

1

To use Infura with web3 v0.20 and to be able to sign transaction you need a provider engine.

4
  • Are these links supposed to be useful? This answer is NOT helpful at all...
    – Jim
    Commented Oct 29, 2021 at 14:25
  • @Jim Those links were valid for web3 v0.20 on April 2019. Web3 is now at v1.5, and Truffle is using a mono repo as of October 2021, so yes the answer is outdated.
    – Ismael
    Commented Oct 29, 2021 at 14:40
  • @Jim This answer ethereum.stackexchange.com/a/46002 fixes a similar issue and it updated to web3 v1.0 and it should work with current version.
    – Ismael
    Commented Oct 29, 2021 at 15:00
  • Posting links with zero explanation is NOT a good answer. You may want to go read a guide and learn how to do it properly.
    – Jim
    Commented Oct 29, 2021 at 16:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.