0

I'm trying to use personal_sign and getting not supported error. I'm using web3 v 0.20.1

I first tried using infura and was not able to resolve the issue, so then I connected to a geth node with this setup: geth --rpc --rpcport "8434" --rpccorsdomain "*" --ipcdisable --rpcapi "db,eth,net,web3,personal" --networkid 4

I've not been able to understand how to access this personal_sign method despite being able to access the web3.currentProvider object.

**Edit - seems to now be solved with version 1.0.0 + if the personal flag is set for rpcapi. Is there any way to set this flag when using infura?

1

To use Infura with web3 v0.20 and to be able to sign transaction you need a provider engine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.