1

I've typed targetgaslimit option, however it has returned the following error.

enter preformatted text here flag provided but not defined: -targetgaslimit

The following is the command.

$ geth --networkid "11" --nodiscover --datadir "hoge" --genesis "/hoge/myGenesis.json" --port "1234" --mine --targetgaslimit "4712388" --unlock myCoinbase --rpc --rpcaddr "localhost" --rpcport "8545" --rpccorsdomain "*" console

Is the targetgaslimit option eliminated?

  • why do you have it twice in your cmd line?\ – Roland Kofler Jul 11 '16 at 5:39
  • Sorry, it's a mistake.I've edited it. – lalala Jul 11 '16 at 5:41
  • and does it work now, because mine works... – Roland Kofler Jul 11 '16 at 5:41
  • Is it work in your condition? I'll try it. – lalala Jul 11 '16 at 5:44
  • @RolandKofler It didn't work in my condition. – lalala Jul 11 '16 at 5:47
1

The --targetgaslimit flag was added in this commit, which was included in version 1.4.0. If you're running an earlier version you'll need to update.


How to determine which release it's in:

On the page showing the committed code there's a blue box at the top showing the commit comment. At the bottom of that box is a line that says Master, which is the name of the branch, and a tag icon, which shows v1.4.9 (which is the current version). Clicking on the ... icon next to the tag shows a list of release versions in which this commit is incorporated. The first (oldest) one is v1.4.0.

  • I hadn't read the extended chat discussion that Roland had with the OP. The recommendation there was also to update to at least 1.4.0 - happy to delete my answer and let Roland have credit :) – Richard Horrocks Jul 11 '16 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.