1

So I'm a complete newbie and trying to deploy my first smart contract to a local Ethereum blockchain. I'm doing this on a Windows machine.

I have created a private blockchain using geth, made an account and started mining. The account is unlocked. This is the command I use to start the node:

geth --datadir "%my_node_path%" --rpc --rpcport 8545 --rpccorsdomain "*" console 2>console.log

Then I installed the remix-ide node module and created a simple smart contract. It compiles, so no problem there.

In order to connect the Remix IDE to my blockchain, I changed the environment to Web3 provider. Seems that the connection works as the account ID shows up correctly and the ether amount updates as I mine.

Screenshot of remix IDE environment and account

Now, if I listen on the network, the console shows the mined blocks, but when I try to deploy my contract, the Remix console shows this:

creation of greeter pending...

[block:1746 - 0 transactions]

Then if I do txpool.status from the command line on my blockchain, it doesn't show the transaction:

txpool.status { pending: 0, queued: 0 }

Why isn't the smart contract deploying? I am strictly following a tutorial. Have been trying to find an answer for the past day, with no luck.

  • Do you mean geth console or Remix console? Try running geth with --verbosity 5 and see what happens in geth console when you try to deploy your contract. – Mikhail Vladimirov Apr 18 at 13:59
  • Yeah sorry, I meant the Remix console. I've edited the question. I tried running geth with --verbosity 5, but it does not seem to show anything when I tried to deploy the contract – iuwqyir Apr 19 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.