0

I know there are already a lot of topics that deal with the problem but their solutions didn't work for me.

this is the code:

pragma solidity ^0.5.2;


import "https://github.com/OpenZeppelin/openzeppelin-solidity/contracts/token/ERC721/ERC721Full.sol";
import "https://github.com/OpenZeppelin/openzeppelin-solidity/contracts/token/ERC721/ERC721Mintable.sol";

contract MyNFT is ERC721Full, ERC721Mintable {


  struct Structure{
      string name;
      uint id;
  }
  Structure[] public listOfStructure;
  address public owner;
  constructor() public{
      owner = msg.sender;
  }


  function create(string memory _name) public{
      uint id = listOfStructure.length;
      listOfStructure.push(Structure(_name, id));
      mint(owner, id);
  }

}

Remix says "This contract does not implement all functions and thus cannot be created.", I just started using nft so I know it could be a concept error, for example I didn't understand the concept of interface very well, but I don't think it's the same problem (maybe).

I tried to deploy with truffle but I have a similar error.

Thanks and sorry for the duplicate!

  • You must implement all the not implemented functions of ERC721Full and all the not implemented functions of ERC721Mintable. – goodvibration Apr 16 at 13:42
1

I solved using 0xcert instead of openzeppelin.

  • Thank you, would you please post the code too – William Entriken Apr 17 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.