I just made some updates to my contracts and tried to redeploy them - but I'm getting this message, over and over again.

enter image description here

Its not even attempting any of the migrations - it just goes right to this message - and obviously, despite what its saying, everything is not up to date.

I also tried adding the --reset flag to my migration command - same result.

I also deleted the build folder and did everything again: re-compiled, then tried the migration again - same result:

Everything is up to date ...

Any idea what's going on?


try to delete the build directory of Truffle or to add --reset to your command.

A compilation of the former contract is still there and Truffle is not aware of your changes.

  • Oh I did all those things - several times. I forgot to mention that in my question - but I'll update it now so people know I've done that. (thank you though!) – Mark55 Apr 11 '19 at 12:05
  • ok. And what about your migrations files ? Would you mind sharing them ? Maybe ... – qCazelles Apr 12 '19 at 13:06

I'm assuming you're using Truffle HDWallet Provider with an Infura node. If so, go in truffle.js (or truffle-config.js) and under the ropsten provider (under networks), try passing the Infura API URL with https://. So it should look like this:

// Inside truffle.js

// imports

module.exports = {

  networks: {

    ropsten: {
      provider: function() {
        return new HDWalletProvider(YOUR_MNEMONIC, "https://ropsten.infura.io/v3/YOUR_KEY")
      network_id: 3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.