1

I set a Private net with Geth. and use miner.start() to mine blocks. my default account is 0x59a4155889e72de7846da695672d87f0e6da7332 in the keystore folder.

PROBLEM: before 3000 blocks, the block's coinbase is 0x59a4155889e72de7846da695672d87f0e6da7332 which is my default account, but when mining for 3000 blocks, the 3001 block's header.coinbase become 0x6ad5c14743b1fb28c012c877824d5b07c0ebc2ed which i have never seen... so anybody know why?

  • Is miner RPC api enabled in your node? How did you launch your node? – Ismael Apr 3 at 19:51
  • yes,i did enable my RPC, so you mean someone set the miner via RPC? – zxxhere Apr 4 at 3:43
  • If your node has a public IP and the miner RPC api is enabled then it is possible to change the etherbase using miner.setEtherbase(). – Ismael Apr 4 at 16:34
  • ok,i see。 some bad guy changed my private net coinbase, via the way you said. – zxxhere Apr 9 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.