3

Does Ethereum have any reliable Wallet software for sending/receiving ether on Windows?

I saw that Mist Wallet was highly recommended so I tried it.

  • It took 10 hours to start up (since it downloads the entire blockchain)
  • Somehow it set up a "main account" without asking me for a password. I was going to transfer funds to that account but luckily I googled a bit first and found that if I would have transferred funds to my "main account" I would have lost those funds due to not having the password.
  • The GUI apparently has no function for checking if you have the password to an account or not. The only way to find out if you can actually access an account is if you send money to the account first and then try to send it out. Personally, I would prefer to know if I have access to an account before I send money to it...
  • I created some accounts and asked a friend to transfer 0.001 ether to me. Then I tried transferring that ether between my acconts. What usually happens is the transaction shows up in the transaction list with "0/12 confirmations". After a few minutes it just disappears and I get no notification what went wrong. Sometimes the entire Wallet GUI turns white and unresponsive and I have to restart it. After trying for hours I still have not been able to make a transfer with the Mist Wallet.
3

Yo Atte!

Low startup time: This is a known problem. In the future is to plan to have archival nodes which allow you to stream the whole blockchain faster to your machine. Furthermore in the future most users are most likely going to use light clients (think Electrum for Bitcoin) that do not blockchain at all. Unfortunately those are not ready yet for the mainstream adoption.

Setting up an account without asking for a password, no way to check if the account has password or not: This is a bad usability issue. Please report it here https://github.com/ethereum/mist/issues

Sending does not work: Something definitely goes wrong here. Do you get transaction id? It always sounds like the wallet is not connected to a network, tries to broadcast the transaction and because it cannot reach any Ethereum nodes it fails back. But if the transaction just disappears, without an error, this is a usability issue and should be reported in the link above.

  • Thanks. The current block is updated correctly so I guess I'm connected. I get a transaction id, but etherscan doesn't find any transaction with that id. I reported the issues on GitHub. – Atte Juvonen Jul 7 '16 at 18:28
  • If etherscan doesn't see the transaction id it means your wallet failed to broadcast the transaction for some reason. However I am not well versed in Ethereum protocol to know what those reasons could be and could they be as trivial as some firewalling issue. – Mikko Ohtamaa Jul 8 '16 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.