So I already went through this query, but I still couldn't get my doubt solved. Be it any Blockchain Dapp, the same error is coming for me. I used the marriage certificate and kickstart examples.

Can anyone please help me with this?

  • Could you explain what do you want, what are you doing to achieve this, and what do you get instead of desired result? Commented Mar 29, 2019 at 13:48

2 Answers 2


In your DApp you are probably calling some of those Web3 API functions that do publish transactions to blockchain (e.g. web3.eth.sendTransaction), or some non read-only functions of some smart contracts. And you probably didn't provide value for from parameter, i.e. you didn't tell what private key to use to sign the transaction.

As long as every transaction has to be signed by some private key before being published into blockchain, you transactions cannot be published, and thus you get error message.

Regarding your code, your probably just don't have any accounts.

  • Here-in is a snippet of my code Commented Mar 29, 2019 at 16:07
  • onSubmit = async(event) =>{ event.preventDefault(); this.setState({loading: true, errorMessage: ''}); try{ const accounts = await web3.eth.getAccounts(); await factory.methods.createCampaign(this.state.minimumContribution) .send({ from: accounts[0] }); //we want to redirect our user to the campaignIndex, root route: / Router.pushRoute('/'); }catch(err){ this.setState({errorMessage: err.message }); } this.setState({loading: false}) }; render(){ Commented Mar 29, 2019 at 16:08
  • Put it into original question, please. Commented Mar 29, 2019 at 16:15

It seems you are providing a from parameter when executing the send function. In that case, make sure the node you are using has accounts already created, and those accounts have funds.

If you are using ganache it all should be ready out of the box. Otherwise you're probably using geth in a testnet. In that case you must create an account there and send some ether through a faucet (or real ether if on mainnet).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.