My Metamask address wont show up on remix-ide either run on localhost and remix.ethereum.org

remix shows like this

I also have tried it on brave and chrome, none of them show the address. please help me :(

1 Answer 1


first you should unlock your metamask, then go for the remix and select "injected web3". If the metamask is locked or doesn't have any imported account,the following account section in the remix will be empty.Hope its helps. Important : please check that in metamask setting the privacy mode is "turned off" , it may also cause problem for external website to access metamask accounts.

  • 1
    thanks mate. My privacy mode is turned on after turn it off, the problem solved.
    – Jonathan
    Commented Mar 28, 2019 at 14:56
  • Thanks. Turning off the privacy mode actually does the trick. :)
    – Senju
    Commented May 1, 2019 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.