0

I have been trying to follow the following tutorial

[https://github.com/adamyala/Your_First_Decentralized_Application_Python] But the following error occurs: enter image description here

I have followed all the steps in the tutorial. Also, I have made sure that solc is installed using npm install -g solc in the virtualenv.

Is there anybody that can help?

Many thanks.

1

It sounds like you're installing solc-js but your code (via the py-solc library) requires solc. It's possible you can get away with renaming (or symlinking) solcjs to solc, but I think the two have different command-line interfaces.

A better solution is to actually install solc. See https://solidity.readthedocs.io/en/latest/installing-solidity.html for instructions on how to do that on various platforms.

0

first you are using py-solc then npm package doesnt mean anything to python. And have you run pip install -r requirements.txt if yes then try manually install it using: pip install py-solc

  • I have already run pip install -r requirements.txt and py-solc but it comes with the same error – Nicolas Manea Mar 15 at 1:11
  • are you sure your python is 3.6+ try running it again with python3 command – haxerl Mar 15 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.