2

I am trying to add the constantinople fork to my private net with is running on geth. I have updated to latest geth, geth 1.8.23.

I have stopped my current geth node running and have chnged the genesis file by adding constantinople block as below in config file

"config": { "chainId": 56312, "homesteadBlock": 0, "eip155Block": 0, "eip158Block": 0, "constantinopleBlock": 16275, "byzantiumBlock": 0 }

However, when I try to init the geth with new config, O am getting below error

Fatal: Failed to write genesis block: mismatching Constantinople fork block in database (have <nil>, want 16275, rewindto 16274)

Could someone help me to add constantinople fork to my private net.

2

I tried this and worked (but I recommend to create a backup):

1-alter the .json file in the addind "constantinopleBlock": 16275

2- put the command: geth --datadir init .json

and the chain remains but the admin.nodeinfo is updated

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.