0

I have a geth node running on my laptop. This is the command I used to start geth.

geth --port 4321 --networkid 1234 --datadir=./dataDir  --rpc --rpcport 8543 --rpcaddr 127.0.0.1  --rpcapi "eth,net,web3,personal,miner"

geth attach http://127.0.0.1:8543/

I have the truffle folder structure as below:

truffle folder structure

This is my truffle-config.js

**
 * Use this file to configure your truffle project. It's seeded with some
 * common settings for different networks and features like migrations,
 * compilation and testing. Uncomment the ones you need or modify
 * them to suit your project as necessary.
 *
 * More information about configuration can be found at:
 *
 * truffleframework.com/docs/advanced/configuration
 *
 * To deploy via Infura you'll need a wallet provider (like truffle-hdwallet-provider)
 * to sign your transactions before they're sent to a remote public node. Infura API
 * keys are available for free at: infura.io/register
 *
 * You'll also need a mnemonic - the twelve word phrase the wallet uses to generate
 * public/private key pairs. If you're publishing your code to GitHub make sure you load this
 * phrase from a file you've .gitignored so it doesn't accidentally become public.
 *
 */

// const HDWalletProvider = require('truffle-hdwallet-provider');
// const infuraKey = "fj4jll3k.....";
//
// const fs = require('fs');
// const mnemonic = fs.readFileSync(".secret").toString().trim();

module.exports = {
  /**
   * Networks define how you connect to your ethereum client and let you set the
   * defaults web3 uses to send transactions. If you don't specify one truffle
   * will spin up a development blockchain for you on port 9545 when you
   * run `develop` or `test`. You can ask a truffle command to use a specific
   * network from the command line, e.g
   *
   * $ truffle test --network <network-name>
   */
   rpc: {
    host:"localhost",
    port:8545
},
  networks: {
    // Useful for testing. The `development` name is special - truffle uses it by default
    // if it's defined here and no other network is specified at the command line.
    // You should run a client (like ganache-cli, geth or parity) in a separate terminal
    // tab if you use this network and you must also set the `host`, `port` and `network_id`
    // options below to some value.

     development: {
       host: "127.0.0.1",     // Localhost (default: none)
       port: 8545,            // Standard Ethereum port (default: none)
      network_id: "*",
      from: 0x2e0d45a887c8120d7bc6a3d06aec5214270902ba,
      gas:8500000,
      gasPrice:2000000000,       // Any network (default: none)
     },

    // Another network with more advanced options...
    // advanced: {
      // port: 8777,             // Custom port
      // network_id: 1342,       // Custom network
      // gas: 8500000,           // Gas sent with each transaction (default: ~6700000)
      // gasPrice: 20000000000,  // 20 gwei (in wei) (default: 100 gwei)
      // from: <address>,        // Account to send txs from (default: accounts[0])
      // websockets: true        // Enable EventEmitter interface for web3 (default: false)
    // },

    // Useful for deploying to a public network.
    // NB: It's important to wrap the provider as a function.
    // ropsten: {
      // provider: () => new HDWalletProvider(mnemonic, `https://ropsten.infura.io/${infuraKey}`),
      // network_id: 3,       // Ropsten's id
      // gas: 5500000,        // Ropsten has a lower block limit than mainnet
      // confirmations: 2,    // # of confs to wait between deployments. (default: 0)
      // timeoutBlocks: 200,  // # of blocks before a deployment times out  (minimum/default: 50)
      // skipDryRun: true     // Skip dry run before migrations? (default: false for public nets )
    // },

    // Useful for private networks
    // private: {
      // provider: () => new HDWalletProvider(mnemonic, `https://network.io`),
      // network_id: 2111,   // This network is yours, in the cloud.
      // production: true    // Treats this network as if it was a public net. (default: false)
    // }
  },

  // Set default mocha options here, use special reporters etc.
  mocha: {
    // timeout: 100000
  },

  // Configure your compilers
  compilers: {
    solc: {
       version: "0.6.0",    // Fetch exact version from solc-bin (default: truffle's version)
      // docker: true,        // Use "0.5.1" you've installed locally with docker (default: false)
      // settings: {          // See the solidity docs for advice about optimization and evmVersion
      //  optimizer: {
      //    enabled: false,
      //    runs: 200
      //  },
      //  evmVersion: "byzantium"
      // }
    }
  }
}

This is the smart contract I have:

pragma solidity >=0.4.18;

Contract HelloWorld {

    function hi() public pure returns (string) {

        return (“Hello World”);

    }

}

My 2_deploy_contracts.js:

var HelloWorld = artifacts.require("./HelloWorld.sol");
module.exports = function(deployer) {
   deployer.deploy(HelloWorld);
};

When i run truffle compile, nothing happens and truffle migrate also doesn't return any information. I tried using ganache instead of the geth node. Still, it is not working. I am running the node from my macbook pro laptop. I am not sure if a port needs to opened or something is wrong with the contract. Please help

Thanks in advance skr

1

Thank you. Truffle compile was failing silently because my account didn't have permissions to run the command. I didn't have execute permissions on the folder in which truffle had it's configuration and installation files. But, Truffle never complained about it. But, when I ran the command as sudo (WHICH IS NOT RECOMMENDED), it worked and I got my build folder for the project. Then, I went ahead and changed permissions on the folder for my account to have execute privilege. Then, both Truffle compile and Truffle migrate worked fine. Another important thing to ensure is that you use the correct port number in truffle-config.js which was my issue in the beginning. Also, make sure you use the syntax available in the corresponding solidity version.

0

Code was mostly correct, the following should compile.

pragma solidity >=0.4.18;

contract HelloWorld {

    function hi() public pure returns (string memory) {
        return ("Hello World");
    } 
}

You do not use truffle compile from inside the geth node.
You use it from the parent directory of your truffle project.

In regards to calling truffle migrate, I would recommend opening a truffle console that is connected to your blockchain and doing it from there.

First change the networks object in truffle-config.js to be the following.

networks: {
  development: {
    host: "127.0.0.1",     
    port: 8545,            
    network_id: "*",
    from: 0x2e0d45a887c8120d7bc6a3d06aec5214270902ba,
    gas:8500000,
    gasPrice:2000000000,       
  },

// Private Blockchain
  private: {
    port: 8543,             // Custom port
    network_id: 1234,       // Custom network
    gas: 4000000,           // Gas sent with each transaction (default: ~6700000)
  }
}

Now call truffle console --network private from the parent directory. From this console you should be able to deploy your contracts to your testnet with migrate --reset

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.