I wonder why I get the error when I have v0.5.0 everywhere and do the following:

In my Action.sol: pragma solidity ^0.5.0;

In Migrations.sol: pragma solidity >=0.5.0 <0.6.0;

When running truffle compile I get:

Error: Could not find a compiler version matching 0.5.0. Please ensure you are specifying a valid version, constraint or build in the truffle config. Run `truffle compile --list` to see available versions.

In test-a-smart-contract-with-truffle/truffle-config.js:

  compilers: {
    solc: {
      version: "0.5.0", 

In /usr/local/bin/truffle:

compilers: {
      solc: {
        version: "0.5.0",
        settings: {
          optimizer: {
            enabled: false,
            runs: 200
          evmVersion: "byzantium"
      vyper: {}

But when I run truffle compile --list I get:

 ".. and 38 more. Use `--all` to see full list."

In my case, I run this following command in order to update truffle: npm install -g truffle@5.0.21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.