0

Experienced iOS developer here - but very new to Ethereum Smart Contract development.

I'm trying to figure out why the web3 version that gets loaded by MetaMask into my browsers when I run my app (or dApp) is version 0.20.3 - even though I just did fresh installations of Truffle, web3, etc., which means that it should be loading web3 v. 1.0.0-beta.46.

Also, when I run truffle --version from Terminal, it says

MacBook-Pro-3:election johnM$ truffle version
Truffle v5.0.4 (core: 5.0.4)
Solidity v0.5.0 (solc-js)
Node v11.10.0

So I'm thinking I should be up to date.

As as aside: is the web3 object that gets loaded into the browser during runtime totally not related to the version of web3.js that I downloaded (using npm)? Or does the web3 object that get loaded have to do with what version of MetaMask I'm running? (I'm on version 6.0.1)

I'm a bit confused on all that as well.

  • 1
    If I'm not mistaken the web3 instance injected into your browser by MetaMask has nothing to do with the one used in your Truffle installation. – Gabe Feb 18 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.