1

I am trying to run geth --light --cache 64 --rinkeby but it stucks on

INFO [02-12|08:58:16] IPC endpoint opened: /home/pi/.ethereum/rinkeby/geth.ipc.

I am using geth on a Raspberry.

The full output is:

geth --light --cache 64 --rinkeby
INFO [02-12|08:58:16] Starting peer-to-peer node               instance=Geth/v1.7.3-stable-4bb3c89d/linux-arm/go1.7.4
INFO [02-12|08:58:16] Allocated cache and file handles         database=/home/pi/.ethereum/rinkeby/geth/lightchaindata cache=64 handles=1024
INFO [02-12|08:58:16] Initialised chain configuration          config="{ChainID: 4 Homestead: 1 DAO: <nil> DAOSupport: true EIP150: 2 EIP155: 3 EIP158: 3 Byzantium: 1035301 Engine: clique}"
INFO [02-12|08:58:16] Loaded most recent local header          number=10815 hash=d783a3…2cb71d td=21429
INFO [02-12|08:58:16] Starting P2P networking 
INFO [02-12|08:58:16] RLPx listener up                         self="enode://b8f1470420a00d38eef1d248c81fa6339af942bf2eaeb62b46ba26f3db6a0f1435b23486b741e5d998a681213e7cf467f3b1096497af10267499ac7b0f9099df@[::]:30303?discport=0"
WARN [02-12|08:58:16] Light client mode is an experimental feature 
ERROR[02-12|08:58:16] Failed to retrieve current release       err="can't fetch trie key ff59dc520c6c214bf3711461287c619f740a46852d93cc5a8e998966582e7cf3: no suitable peers available"
INFO [02-12|08:58:16] IPC endpoint opened: /home/pi/.ethereum/rinkeby/geth.ipc

I tried the same command on my macOS Mojave and it works fine, after opening IPC endpoint it continues importing blocks and states.

Should I assume it's a problem with the machine on which the geth is running?

0

which version of geth are you using? I had the same problem on 1.7.3 then I upgraded to latest armv7 build which is 1.8.23 as of now. then blocks I could see block headers. I could not see my ethers on Pi and also was unable to find any peers. but after upgrade, it worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.