2

Truffle v5.0.3 config:

truffle-config.js

module.exports = {
  // See <http://truffleframework.com/docs/advanced/configuration>
  networks: {
    development: {
      host: "127.0.0.1", //also tried 'localhost', just in case
      port: 7545,
      network_id: "5777"
    }
  }
};

Ganache v1.3.0 configganache gui default settings

on executing truffle migrate --reset or truffle compile or truffle migrate --network development --reset --compile-all --verbose-rpc happens nothing: no output, no builds. I suppose the same code worked before (with output and builds), however, on the different OS (using Linux Debian at the moment).

What is wrong with the configuration?

Edit: Ganache logs show there is no connection from truffle during my attempts to compile contracts.

[9:09:57 PM] Starting server (version 1.3.0) with initial configuration: {"hostname":"127.0.0.1","port":7545,"network_id":5777,"default_balance_ether":100,"total_accounts":10,"unlocked_accounts":[],"locked":false,"vmErrorsOnRPCResponse":true,"verbose":false,"gasLimit":6721975,"gasPrice":20000000000,"hardfork":"constantinople"}
[9:09:57 PM] Ganache started successfully!
[9:09:57 PM] Waiting for requests...
  • The configuration seems to be fine, try deleting the build/ directory in your project. Another thing to check is truffle is correctly installed. – Ismael Feb 8 at 0:59
  • Log shot ... Is it possible you're running from the wrong folder context? You should be in the project root folder with a sub-folder called ./contracts. – Rob Hitchens - B9lab Feb 8 at 22:42
  • @Ismael there is no /build dir yet. Truffle seems to be installed correctly globally, it outputs its version and help. – Poliakoff Feb 10 at 18:52
  • 1
    @RobHitchensB9lab The context is correct. When it's wrong, there is a Could not find suitable configuration file. error message. – Poliakoff Feb 10 at 18:53
  • @Polyakoff Are you runnig ganache and truffle in the same computer? Did you try in a different computer? Is your project available on github? What does truffle compile --all returns? Without more info it can be an issue with truffle installation (try uninstalling a reinstalling), migrations scripts in your project, another problem with your setup. – Ismael Feb 10 at 20:16
0

Rolling back truffle to v4.1.13 resolved my issue. I was able to see error messages (openzeppelin-solidity was a missing dependency), fix errors and build contracts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.