0

I have a network of 3 nodes and I can see that all nodes are listed on the dashboard. However for one of the node, I am see the values of network, protocol and web3 as null.

Also I am not able see the node type for that node in the dashboard. It is blank.

Could someone please help me on it, to know how to get these values displayed.

1 Answer 1

0

When you started the nodes, did you enable the rpc apis? With this flag

./geth --datadir datadir --rpcapi "eth,web3,net"
5
  • Yes the rpc apis are enabled. Still I did not have the values Feb 8, 2019 at 15:39
  • Can you open your browser console and check if any CORS error is logged or if in the network tab the requests are successful?
    – waytosay
    Feb 8, 2019 at 15:45
  • When you say browser console, I presume it is the console of eth-netstats application. There are no errors there. Also I think, network tab is eht-net-intelligence-api application and the requests are successful here. Please correct me if you are asking me to check in something else Feb 9, 2019 at 11:05
  • I mean the actual browser console. Open your application on chrome when it's launched, then right click in page, inspect, console, it will shows errors. On the same window, there's the network tab with all the calls, you can see there if something is failing
    – waytosay
    Feb 11, 2019 at 12:06
  • I have verified the browser details and there are no failures. However, I am trying to remove the eth-net-intelligent-api and add the --ethstats directly in geth console command when we start the chain. I think it will resolve the issue. I will update my observation here Feb 12, 2019 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.