0

I was testing on (Ropsten) Myetherwallet, everything was fine yesterday morning, then that evening, my balances (Ropsten Ether and Tokens) would not show. I was getting "(error_21) Not a valid ERC-20 token" for the tokens.

I checked my balances and transactions on etherscan and they were all there.

So I read the FAQ for Myetherwallet and it said to try swapping to another node, so I tried other nodes infura(Ropsten) and the balances showed again.

My question is why are they not showing in (Ropsten)Myetherwallet node but showing under the infura node even though it was setup under the (Ropsten)Myetherwallet node?

Anybody else seen this problem? Or can explain? Do people have this problem with the Trust and Coinbase ECR-20 wallets?

  • What network (on the top-right corner of the webpage) did you configure MyEtherWallet to work with? – goodvibration Feb 6 at 12:04
  • MyEtherWallet(Ropsten) I m testing my code for the smart contracts. – Trapkang Feb 6 at 12:25
  • Have you tried clearing your cache? If that doesn't resolve the issue, could you try MyCrypto instead? – Wietze Feb 6 at 16:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.