1

i'm getting { [Error: Node error: {"code":-32000,"message":"leveldb: not found"}] when trying to use events on a private eth blockhain.

What might be the problem? (I've installed Leveldb with brew)

Thanks

myContract_ws.events.ContractCreated({
    fromBlock: 0,
}, function(error, event){ console.log("EVENTS log: ",event); })
.on('data', function(event){
    console.log("EVENTS ONDATA",event); // same results as the optional callback above
})
.on('changed', function(event){
    console.log("ContractCreated / CHANGED",event);
})
.on('error',function(err){
  console.log("ERROR HERE");
  console.log(err);
  console.error;

});

geth: 1.8.21-stable web3: 1.0.0-beta.41 macOsX 10.13.6

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.