2

Geth Version v1.8.21+bionic - stable Machine - 16GB Ram, SSD, i7 processor

I'm currently in the process of syncing a full archival node on Geth.

Up until recently the chain was syncing fine, around 5/10 blocks every 10 seconds (has been like this for 3 months on v1.8.18+bionic). With the 1.8.21 upgrade the speed went down drastically at the point where it will never finish (1 block every 20-30 seconds).

Geth is installed using ppa repository, which makes it quite difficult to downgrade back to v1.8.18, moreover with the hard fork coming soon, I'll have to upgrade never the less.

Current Size is at ~ 1.6TB @ Block ~ 6,480,000

I have tried using the --cache 1024 however it still defaults to 512 for some reason. Using: geth --cache 1024 --gcmode archive --syncmode "full"

Any suggestions as to what can be done?

0

Geth 1.8.22-stable seems good

https://github.com/ethereum/go-ethereum/issues/19167

-1

Try running using geth --syncmode=light. Really worked for me. I was able to sync within an hour. You may additionally check the sync progress using command eth.syncing after opening geth javascript console in a different cmd window.

  • 2
    Thanks, but I'd like to specifically run a "full archival node" – LukeAbela Jan 18 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.