0

I've changed my proxywallet from proxywallet 0xB4... to proxywallet 0x5B... in the local.config file.

However, I received mining reward again in previous address: 0xB4... .

Do I need to restart the rig miner after changing the wallet address? Or some additional actions are required to change proxywallet (address that you want your mined funds sent to) ?

Important 1: Here is gethelp link created by ethOS : http://paste.ethosdistro.com/lazovidehu

Important 2: There is another local.config with extension of "save" : local.config.save , such that when I change local.config , yet local.config.save is not changed automatically. Do I need to make changes in both files every time?

Important 3: The content of remote.config is as follows:

#http://ethosdistro.com/pool.txt
#comment out or remove the top line to enable single-rig mode

Important 4: When I use force-local command to disable remote config, I receive: "command not found".

If you need any other information, please let me know.

  • It stands to reason to at least restart the miner application in order for the changes to take effect. As a last resort just reboot the rig. – Micky Socaci Jan 17 at 14:19
  • @Micky Socaci , Thank you, so do you mean after any change in the local.config , I need to restart the rig? And also do I need to do the same changes in another config file with "save" extension (local.config.save) , as I mentioned about this file in my question? Thanks – Questioner Jan 17 at 14:28
1

EthOS is what i use on my rigs as well.

Depending on which files you edit, for example if it's miner app related then you need to do "minestop" then "minestart" for ethOS to reload the miner application and apply new settings, and if you change something like GPU config in local.conf you need to reboot the whole system.

Looking at your helpme result, it does look like you've configured it properly ( local.conf has the wallet you want to get rewards to ) and the remote.conf is empty as it should if you want to manage configs locally.

After you do the wallet change, just wait like an hour for ethermine to show your worker on the new address. https://ethermine.org/miners/0x5Bf39b56e6e1698A01A5116e308e9CDf38787C7d/dashboard does indeed show a miner hashing at around 45-50 mhs, which could be the one you've got running the 4xRX470.

If you're looking to optimise their bioses, clock speeds to get better hashrates i suggest you go on EtherMining subreddit and search for how-to's on exactly that.

In general rebooting the system after configuration changes has yielded good results on my end.

Let me know if that helps.

  • Thank you, the thing I may need to add is that after I received reward in previous address, I restarted the system. So, I now need to wait around a week to receive the next reward to be sure if everything is OK. Just about local.config.save : Do I need to do the same changes in this file? since it is not changed after I change local.config . And do you also know why after commanding force-local in terminal I receive "command not found" ? Thanks – Questioner Jan 17 at 15:00
  • force-local just does not exist, and local.config.save is just a backup of your old configuration. – Micky Socaci Jan 17 at 16:12
  • ,Thank you again, however, I found this command (force-local) from ethOS website (Link to website). Please see the section: "Common Commands on ethOS". – Questioner Jan 17 at 16:16
  • You might be using a version of the OS that does not have it, in any case "force-local" just empties your remote.config file, which you already did. So don't worry about it. – Micky Socaci Jan 17 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.