0

System information
Geth Version: 1.8.20-stable
Go Version: go1.11.2
Operating System: linux
GOPATH=
GOROOT=/home/travis/.gimme/versions/go1.11.2.linux.amd64

Genesis.json

{
"config": {
    "chainId": 110,
    "homesteadBlock": 0,
    "eip155Block": 0,
    "eip158Block": 0
},
"alloc"      : {},
"coinbase"   : "0x0000000000000000000000000000000000000000",
"difficulty" : "0x4",
"extraData"  : "",
"gasLimit"   : "210000",
"nonce"      : "0x0000000000000042",
"mixhash"    : "0x0000000000000000000000000000000000000000000000000000000000000000",
"parentHash" : "0x0000000000000000000000000000000000000000000000000000000000000000",
"timestamp"  : "0x00"

}

Issue
Using geth I am running a private chain (locally), starting it as follows:

 ./geth --datadir /home/dx/geth/privatechain init /home/dx/geth/privatechain/genesis.json

And:

 ./geth --datadir /home/dx/geth/privatechain --nodiscover --maxpeers 0 --metrics --networkid 110 console

After creating new account, unlocking it, and setting it on Ether base, the mining process was stuck at the first new mining work as following picture: enter image description here

To tackle this issue, I have regenerated DAG but it had no effect. I also ran this command on the other ubuntu offline and succeeded in starting new mining work. So, I thought it could be attributed to the low memory. I expanded virtual memory to 7.8GB requested from hard disk, but it failed either, even though eth.mining is ture.

Now I do not know how to solve this issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.