4

I wanted to deploy the contract with the Ledger Nano S wallet, but not working on truffle. I installed npm package 'truffle-ledger-provider' and followed the practice. But I got an error ReferenceError: regeneratorRuntime is not defined when I tried to deploy. I've searched google, but there was no good solution. Please help me.

2
  • What OS you have?
    – ferit
    Jan 7 '19 at 17:12
  • I use MacOS @ferit
    – Jung Chun
    Jan 8 '19 at 3:46
0

Here's the fix. I just ran into this issue today.

// truffle-config.js
const regeneratorRuntime = require("regenerator-runtime");

Then install the NPM package: npm install regenerator-runtime

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.