0

I am trying to deploy this contract on a private permissioned Quorum network. The migration fails on the 1_initial_migration process. If I try to repeat the process with:

sudo truffle migrate --network development --reset 

I don't get any output on the console at all. When I try to deploy another contract with other network configurations I also get no output to the console. Without a console output it is hard to find out what is wrong.

Is this normal behaviour of truffle?

Here is the first migration process, which failed. The eth.blockNumber was increased after this, even if it failed.

What does the error stand for: Error: Number can only safely store up to 53 bits ?

Starting migrations...
======================
> Network name:    'development'
> Network id:      1337
> Block gas limit: 3758096384


1_initial_migration.js
======================

   Deploying 'Migrations'
   ----------------------
   > transaction hash:    0xd56cfd9d7bfa56b2s30138bb9a348069e40e92c2b41da87a081f2070560075
   > Blocks: 0            Seconds: 0
   > contract address:    0x17D3233DD54d2491b68c62b534Da313c29456A39
   > account:             0xC58A28d310c76e8298FA456381E6F2da9F046V54
   > balance:             1000000000
   > gas used:            245462
   > gas price:           0 gwei
   > value sent:          0 ETH
   > total cost:          0 ETH


   ⠋ Saving migration to chain.Error: Number can only safely store up to 53 bits

EDIT: My truffle-config.js looks as follows:

   development: {
        //provider: () => new HDWalletProvider("privateKey", "http://127.0.0.1"),
        host: "127.0.0.1",  
        port: 22000,          
        network_id: "*",      
        from: "0xC58A28d310c76e8298FA456381E6F2da9F046V54",
        gasPrice: 0,
        gas: 4500000
    },
1

You do not mention what Quorum config was for this, but we have seen this issue before with Truffle and Quorum running in Raft consensus mode. Please see this https://github.com/jpmorganchase/quorum-examples/issues/148

  • Thank you for the answer. What exactly would you like to know? I am running raft, I am starting it with --permissioned or do you mean with config the config field within the genesis.json – saitam Jan 7 at 20:58
  • I mean contents of your genesis.json, but cli options also are useful for determining the issue. – fixanoid Jan 9 at 22:51
0

You're setting an exceedingly high block gas limit. Try reducing it to below 2147483647.

PS You might also like to look at Etherlime, which provides a nice alternative to truffle migrations that's simpler and has fewer ways to go wrong.

  • Not the gas limit of your transaction, the network's block gas limit. – Edmund Edgar Jan 7 at 10:13
  • I haven't used quorum but I guess your mining/validating nodes have a genesis.json or similar? It should be in there. – Edmund Edgar Jan 7 at 11:52
  • I have set the chain gas limit via the flag --targetgaslimit 2000000000 but still doesn't help – saitam Jan 7 at 16:36
  • Hi, Quorum basically ignores gas limit configuration since it doesnt operate quiet like geth does. Most likely this is unrelated to the issue. Thanks, – fixanoid Jan 7 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.