-1

I made a smart contract in Remix-Solidity IDE, when I compiled it I had no errors and I was able to remove the contract but when I tried to use the truffle for my Dapp and compiled it it showed me this error.

enter image description here

this is the warning that shows remix-solidity, some tell me that it is necessary to declare if they are public or private, I made the same changes but it does not let me compile.

enter image description here

  • Can you share more details (exceptions, smart contract code). it might be a compiler version issue. – Greg Jeanmart Jan 1 at 18:55
  • there are the warnings, even if I display the contract in the network rinkeby and use the functions of the contract and I registered all the transactions. Now I was trying to make an app that consumes the contract. – Nicolas Flores Muñoz Jan 1 at 19:12
  • Perhaps there is a mismatch in complier versions? In any case we need more details :), at least can you post the contract itself? – GrandFleet Jan 2 at 5:37
  • In the end it is mismatch of the truffle compiler, the version it uses is 0.5.0 – Nicolas Flores Muñoz Jan 2 at 18:53
1

the problem was that the truffle framework had a different version of the solidity pragma, my contract used the 0.4.23 and truffle 0.5.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.