0

I have some questions using geth.

Currently I am using the following version of geth.

Geth
Version: 1.8.20-stable
Git Commit: 24d727b6d6e2c0cde222fa12155c4a6db5caaf2e
Architecture: amd64
Protocol Versions: [63 62]
Network Id: 1
Go Version: go1.10.4
Operating System: linux
GOPATH =
GOROOT = / usr / lib / go-1.10
  1. When you run geth, the memory usage grows slightly to over 90%. Is this symptom normal?

  2. The difference between the current block of ethereum and the current block of the ether node I have is not reduced to less than 30,000. Is this symptom normal?

{   currentBlock: 6935214,   highestBlock: 6965271,   knownStates: 249970684,   pulledStates: 249970684,   startingBlock: 6958744 }

Here is the hardware specification of the Ethereum node I currently have.

grep -c processor / proc / cpuinfo
 - 8
grep ^ processor / proc / cpuinfo | wc -l
 - 8
grep 'cpu cores' / proc / cpuinfo | tail -1
 - cpu cores: 4

cat / proc / meminfo | grep Mem
MemTotal: 8133180 kB
MemFree: 2843816 kB
MemAvailable: 3533660 kB

geth CLI Options are as follows.

--maxpeers 50 --maxpendpeers 25 --cache = 2048 --syncmode "fast" --rpc --rpcport "8545" --rpcaddr "000.000.000.000" --rpccorsdomain " net, web3, personal, admin "--datadir / home / hdd / block_data / eth_data
0

Yes, cache of 2048 will require higher amount of memory. You can reduce it to a lower number ( --cache = 768 ) , that should reduce memory usage.

  • Thank you for answer. I have modified the geth CLI option. It will take a little while, but memory usage will increase to over 90% even if you modify options. is there any other way? – ASH Dec 28 '18 at 5:29
0

When you run geth, the memory usage grows slightly to over 90%. Is this symptom normal?

Yes, that is how the linux manage memory. Linux is borrowing unused memory for disk caching. This makes it looks like you are low on memory, but you are not! Everything is fine! Read this

The difference between the current block of ethereum and the current block of the ether node I have is not reduced to less than 30,000. Is this symptom normal?

Yes. That's also normal. As long as the command eth.syncing returns an object, your node is syncing.

  • Thank you for your answer. I have one more question. Now I have an Ethereum node that I have "startingBlock: 6958744" and "currentBlock: 6935214." While synchronizing block data, can "currentBlock" be lower than the "startingBlock" value? – ASH Dec 31 '18 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.