After making all the client side scripts inside a folder which are needed for my website (in dist folder)

checked with ipfs swarm peers : shows many results

then adding the files with ipfs add -r dist/

proceeded with ipfs name publish < root hash ie hash of dist >

when in browser gateway.ipfs.io/ipfs/<new_given_hash>

the browser keeps loading and no errors in ipfs daemon running terminal

2 Answers 2


I am having the exact same issue over the last week. When my directory is added, it initially does not load in my browser at the hash address. However, it seems to solve itself intermittently if I check back in about 1 hour, but trying again after another hour it is again not working. Not sure what's going on, perhaps an issue with IPFS?

My current checklist:

  • ipfs swarm peers (to check connected to peers)
  • ipfs add -r "directory"
  • check on your local gateway - http://localhost:8080/ipfs/< your hash >

If it's not loading, wait an hour or two and check. This has worked for me intermittently.

  • Yeah I got that issue solved by that way only, ipfs network in not consistent and not maintained... So gateways generally don't work, when you are accessing through localhost:8080 you are actually taking service from your node only so, it will work every time your daemon is up and running.... Dec 18, 2018 at 8:31

I had this problem, but now it works, check this link: https://github.com/mortezaalizadeh66/IPFS-Solution/issues/1

  • 2
    Avoid link answer only. Explain what, why and how. May 25, 2020 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.